Excel
<<  Статические и математические функции excel Встроенный динамический SQL  >>
Логические функции в Excel
Логические функции в Excel
Логические высказывания – это повествовательное предложение, в
Логические высказывания – это повествовательное предложение, в
Какое предложение является логическим высказыванием
Какое предложение является логическим высказыванием
Высказывания бывают:
Высказывания бывают:
Логические операции
Логические операции
В электронных таблицах Excel для составления логических высказываний
В электронных таблицах Excel для составления логических высказываний
Определить, принадлежит ли точка с координатами (x,y) выделенной
Определить, принадлежит ли точка с координатами (x,y) выделенной
Область C пересечение плоскостей (конъюнкция): (y>0),(x<0) и
Область C пересечение плоскостей (конъюнкция): (y>0),(x<0) и
(y>0) & (x<0) & ((x^2+y^2)<4) + ((x^2+y^2)>4) & ((0<x) & (x<2) &
(y>0) & (x<0) & ((x^2+y^2)<4) + ((x^2+y^2)>4) & ((0<x) & (x<2) &
ИЛИ (И(B2>0; A2<0; (A2^2 + B2^2) < 4); И((A2^2+B2^2)>4; 0<A2; A2<2;
ИЛИ (И(B2>0; A2<0; (A2^2 + B2^2) < 4); И((A2^2+B2^2)>4; 0<A2; A2<2;
Определить, принадлежит ли точка с координатами (x,y) выделенной
Определить, принадлежит ли точка с координатами (x,y) выделенной
=ЕСЛИ(И(A2>0;B2<2;B2>0;A2<2;НЕ(И(B2>0;A2>0;A2<1;B2>1)));"принадлежит"
=ЕСЛИ(И(A2>0;B2<2;B2>0;A2<2;НЕ(И(B2>0;A2>0;A2<1;B2>1)));"принадлежит"

Презентация: «Логические функции в Excel». Автор: галина. Файл: «Логические функции в Excel.pptx». Размер zip-архива: 65 КБ.

Логические функции в Excel

содержание презентации «Логические функции в Excel.pptx»
СлайдТекст
1 Логические функции в Excel

Логические функции в Excel

2 Логические высказывания – это повествовательное предложение, в

Логические высказывания – это повествовательное предложение, в

отношении которого имеет смысл говорить о его истинности или ложности .

3 Какое предложение является логическим высказыванием

Какое предложение является логическим высказыванием

Наступил сентябрь. Из далека долго течет река Волга. Дважды два четыре. Во вторник не будет информатики, но будет физика.

4 Высказывания бывают:

Высказывания бывают:

Простые; составные (содержат несколько ложных и/или истинных высказываний, которые соединяются между собой словами и, но, или, а, не).

5 Логические операции

Логические операции

Символы

Слова

Конъюнкция (логическое умножение, пересечение множеств)

&, /\, .

И, а, но (AND)

Дизъюнкция (логическое сложение, объединение множеств)

V, +

Или (OR)

Отрицание (инверсия)

O , – , ‘

Не (NOT)

6 В электронных таблицах Excel для составления логических высказываний

В электронных таблицах Excel для составления логических высказываний

используют функции из категории “Логические”: И(); ИЛИ(); НЕ(); ИСТИНА(); ЛОЖЬ().

ЕСЛИ (<условие в виде логического высказывания>; <действие в случае истинности высказывания>; <действие в случае ложности высказывания>)

7 Определить, принадлежит ли точка с координатами (x,y) выделенной

Определить, принадлежит ли точка с координатами (x,y) выделенной

области

8 Область C пересечение плоскостей (конъюнкция): (y>0),(x<0) и

Область C пересечение плоскостей (конъюнкция): (y>0),(x<0) и

((x^2+y^2)<4) область D пересечение плоскостей (конъюнкция): ((x^2+y^2)>4) и ((0<x) и (x<2) и (-2<y) и (y<0))

Для решения задачи определим выделенную область как объединение (дизъюнкция) областей С и D

9 (y>0) & (x<0) & ((x^2+y^2)<4) + ((x^2+y^2)>4) & ((0<x) & (x<2) &

(y>0) & (x<0) & ((x^2+y^2)<4) + ((x^2+y^2)>4) & ((0<x) & (x<2) &

(-2<y) & (y<0))

Условие для проверки принадлежности точки выделенной области:

10 ИЛИ (И(B2>0; A2<0; (A2^2 + B2^2) < 4); И((A2^2+B2^2)>4; 0<A2; A2<2;

ИЛИ (И(B2>0; A2<0; (A2^2 + B2^2) < 4); И((A2^2+B2^2)>4; 0<A2; A2<2;

-2<B2; B2<0)) Это условие подставляется в ячейку С2 в функцию ЕСЛИ()

Следовательно, используя логические функции и относительные ссылки на ячейки А2 и В2 (где хранятся значения координат (х, у) заданной точки):

11 Определить, принадлежит ли точка с координатами (x,y) выделенной

Определить, принадлежит ли точка с координатами (x,y) выделенной

области

x

y

1

-1

3

5

0

-1

1

-1,8

-1,7

1,7

2

5

5

-1,2

-0,5

0,5

2

2

1,5

1,5

12 =ЕСЛИ(И(A2>0;B2<2;B2>0;A2<2;НЕ(И(B2>0;A2>0;A2<1;B2>1)));"принадлежит"

=ЕСЛИ(И(A2>0;B2<2;B2>0;A2<2;НЕ(И(B2>0;A2>0;A2<1;B2>1)));"принадлежит"

"не принадлежит") =ЕСЛИ(И(B2>-3;B2<4;A2>-2;A2<3;НЕ(И(B2<1;B2>-1;A2<1;A2>-1)));"принадлежит";"не принадлежит")

Ответы

«Логические функции в Excel»
http://900igr.net/prezentacija/informatika/logicheskie-funktsii-v-excel-164827.html
cсылка на страницу
Урок

Информатика

130 тем
Слайды
900igr.net > Презентации по информатике > Excel > Логические функции в Excel