OpenOffice
<<  Назначение и характеристики графического пакета Coreldraw Лев кассиль биография 3 класс  >>
Система Logo Writer
Система Logo Writer
Программирование в среде ЛОГО
Программирование в среде ЛОГО
Лист оглавления системыLogo Writer
Лист оглавления системыLogo Writer
Интерфейс программы ЛОГО
Интерфейс программы ЛОГО
Правила записи команд
Правила записи команд
?Ввод команды или последовательности команд должен заканчиваться
?Ввод команды или последовательности команд должен заканчиваться
Команды для графического исполнителя
Команды для графического исполнителя
КОМАНДЫ ИСПОЛНИТЕЛЮ (черепашке)
КОМАНДЫ ИСПОЛНИТЕЛЮ (черепашке)
Сокращённые формы записи служебных слов
Сокращённые формы записи служебных слов
Повороты черепашки
Повороты черепашки
Назад 90
Назад 90
Решение
Решение
Задание
Задание
Назад 40 направо 90 вперед 20 налево 90 вперед 40 назад 40 налево 90
Назад 40 направо 90 вперед 20 налево 90 вперед 40 назад 40 налево 90
Система Logo Writer
Система Logo Writer
40
40
Организация циклов в среде LogoWriter
Организация циклов в среде LogoWriter
Решение
Решение
Команда повтори
Команда повтори
Вычерчивание окружности
Вычерчивание окружности
Иг повтори 4 [повтори 180 [Вп 1 пр 2] пр 90] сч
Иг повтори 4 [повтори 180 [Вп 1 пр 2] пр 90] сч
Пусть “S 0 пусть “N 1 повтори 12 [вп :N пусть “S :S +:N пусть “N :N +
Пусть “S 0 пусть “N 1 повтори 12 [вп :N пусть “S :S +:N пусть “N :N +
Система Logo Writer
Система Logo Writer
Понятие процедуры
Понятие процедуры
Правила записи процедуры
Правила записи процедуры
Вызов процедуры
Вызов процедуры
Домик
Домик
Вложенные процедуры
Вложенные процедуры
Написать процедуру составления узора из квадрата со стороной 20
Написать процедуру составления узора из квадрата со стороной 20
Узор
Узор
Задание:
Задание:
Назначение функциональных клавиш при наборе процедур
Назначение функциональных клавиш при наборе процедур
Система Logo Writer
Система Logo Writer

Презентация: «Система Logo Writer». Автор: *. Файл: «Система Logo Writer.ppt». Размер zip-архива: 121 КБ.

Система Logo Writer

содержание презентации «Система Logo Writer.ppt»
СлайдТекст
1 Система Logo Writer

Система Logo Writer

2 Программирование в среде ЛОГО

Программирование в среде ЛОГО

Каждая программа для компьютера разрабатывается на одном из языков – языков программирования.

ЛОГО – образовано от древнегреческого «logos», что означает «мысль», «слово».

Язык ЛОГО состоит из: алфавита (буквы – русские, цифры, символы) специально встроенные слова (команды- предложения на языке программирования для указания действия объекту)

3 Лист оглавления системыLogo Writer

Лист оглавления системыLogo Writer

Logo_NEW

Оглавление

С помощью клавиш

Выберите лист

и нажмите клавишу Ввод

Новый лист

Формы

4 Интерфейс программы ЛОГО

Интерфейс программы ЛОГО

Исполнитель «Черепашка»

Рабочее поле

На рабочем поле отображается исполнитель (черепашка) и результаты его действия

Расстояние на рабочем поле измеряется в шагах Черепашки. Один шаг – один пиксель.

Командный центр - для ввода команд на языке ЛОГО

5 Правила записи команд

Правила записи команд

На первом месте пишется название команды, а затем указывается параметры Параметры команды – слово, число или выражение, уточняющее действие команды

Вперед 50

Команда

Параметр

Название команды должно быть написано без ошибок – точно как в словаре. Между буквами в названии команды не должно быть пробелов. Если в команде есть параметр, то он отделяется от названия пробелом, если в одной строке записывается несколько команд, то они разделяются пробелами.

6 ?Ввод команды или последовательности команд должен заканчиваться

?Ввод команды или последовательности команд должен заканчиваться

нажатием клавиши «Enter». ?»ЧИСЛО» в командах вперёд, назад, налево, направо может быть как положительным, так и отрицательным!

7 Команды для графического исполнителя

Команды для графического исполнителя

Вперед (вп)

Число шагов

Продвигается в направлении головы на указанное число шагов

Назад (нд)

Число шагов

Продвигается в направлении против головы

Сотри

Нет

Стирает рисунок, состояние Черепашки сохраняется

Домой

Нет

Устанавливается в центр Рабочего стола, голова смотрит на север

Направо (пр)

Число градусов

Поворачивается направо относительно направления, заданного головой Черепашки

Налево (лв)

Число градусов

Поворачивается налево относительно направления, заданного головой Черепашки

Пп

-

Поднять перо

По

-

Перо опустить

Название команды (краткая форма)

Параметр

Действие исполнителя

8 КОМАНДЫ ИСПОЛНИТЕЛЮ (черепашке)

КОМАНДЫ ИСПОЛНИТЕЛЮ (черепашке)

СЧ – «Спрячь Черепашку»

ПЧ -«Покажи Черепашку»

ИГ - «Исходная Графика»

9 Сокращённые формы записи служебных слов

Сокращённые формы записи служебных слов

Назад нд

Направо пр

Вперёд вп

Налево лв

10 Повороты черепашки

Повороты черепашки

Направо 90

Налево 90

Направо -45

Направо-135

11 Назад 90

Назад 90

90

90

Вперёд 90

Команды НАЗАД 90 и ВПЕРЁД 90

12 Решение

Решение

Иг Вперед 40 направо 90 Вперед 40 направо 90 Вперед 40 направо 90 Вперед 40 направо 90 сч

Задача. Укажите последовательность команд для вычерчивания квадрата со стороной 40.

13 Задание

Задание

Укажите последовательность команд для вычерчивания фигуры «одним росчерком пера»:

14 Назад 40 направо 90 вперед 20 налево 90 вперед 40 назад 40 налево 90

Назад 40 направо 90 вперед 20 налево 90 вперед 40 назад 40 налево 90

вперед 40 направо 90 вперед 40 назад 40 направо 90 вперед 20 направо 90 вперед 120

15 Система Logo Writer
16 40

40

40

40

40

60

80

60

40

40

40

40

40

60

40

40

60

60

17 Организация циклов в среде LogoWriter

Организация циклов в среде LogoWriter

18 Решение

Решение

Иг Вперед 40 пр 90 Вперед 40 пр 90 Вперед 40 пр 90 Вперед 40 пр 90 сч

Задача. Укажите последовательность команд для вычерчивания квадрата со стороной 40.

19 Команда повтори

Команда повтори

Иг повтори 4 [Вперед 40 пр 90]

Повтори <число> [список команд]

Задача: укажите последовательность команд , вычерчивающих равносторонний треугольник.

20 Вычерчивание окружности

Вычерчивание окружности

Иг повтори360 [Вперед 1 пр 1] сч

21 Иг повтори 4 [повтори 180 [Вп 1 пр 2] пр 90] сч

Иг повтори 4 [повтори 180 [Вп 1 пр 2] пр 90] сч

22 Пусть “S 0 пусть “N 1 повтори 12 [вп :N пусть “S :S +:N пусть “N :N +

Пусть “S 0 пусть “N 1 повтори 12 [вп :N пусть “S :S +:N пусть “N :N +

2] ?

23 Система Logo Writer
24 Понятие процедуры

Понятие процедуры

Процедура состоит: 1)из заголовка( служебное слово это и имя процедуры). 2)последовательности команд 3)служебного слова конец.

Процедура – подпрограмма( программа, которую вызывают другие программы).

Пример: это квадрат повтори 4[вперед 40 направо 90] конец

25 Правила записи процедуры

Правила записи процедуры

Для записи процедуры предназначена изнаночная сторона листа. Переход с одной стороны листа на другую осуществляется либо по команде переверни , либо по нажатию клавиш<Ctrl>+<F>

Заголовок и служебное слово конец должны размещаться на отдельных строках.

26 Вызов процедуры

Вызов процедуры

Задание: составьте процедуру вычерчивания прямоугольника со сторонами 50 и 40;

Для вызова процедуры предназначена лицевая сторона листа: набрать в поле команд имя процедуры.

К процедуре можно обращаться из последующих процедур.

Составьте процедуру вычерчивания треугольника со стороной 40;

Составьте процедуру , рисующую домик, используя две предыдущие процедуры.

27 Домик

Домик

28 Вложенные процедуры

Вложенные процедуры

Домик- головная процедура; треугольник, прямоугольник - вложенные процедуры.

это прямоугольник повтори 2[вп 50 пр 90 вп 40 пр 90] конец это треугольник вп 40 лв 120 вп 40 лв 120 вп 40 конец Это домик прямоугольник вп 51 пр 90 треугольник конец

29 Написать процедуру составления узора из квадрата со стороной 20

Написать процедуру составления узора из квадрата со стороной 20

Это квадрат повтори 4[вп 20 пр 90] конец

30 Узор

Узор

Это узор пп лв 90 вп 20 пр90 по (переместили черепашку влево на один квадрат) повтори 3[квадрат пп пр 90 вп 20 лв 90 вп 10 пр 45 по квадрат пп лв 90 нд 20 пр 90 вп 20 лв 45 нд 10 по] сч конец

31 Задание:

Задание:

уменьшить сторону квадрата до 10 пикселей, количество фрагментов узора увеличить вдвое. Задание 2: нарисовать пятиконечную звезду (угол звезды 360)

32 Назначение функциональных клавиш при наборе процедур

Назначение функциональных клавиш при наборе процедур

<F6>удаление символов от курсора до конца строки <f5>переключение алфавита <f1>включение режима выделения текста <f2>запись выделенного фрагмента в буфер( текст с экрана исчезает) (вырезать) <f3>то же(текст не исчезает) (копировать) <f4>вывод на экран с позиции курсора фрагмента из буфера

33 Система Logo Writer
«Система Logo Writer»
http://900igr.net/prezentacija/informatika/sistema-logo-writer-261645.html
cсылка на страницу

OpenOffice

10 презентаций об OpenOffice
Урок

Информатика

130 тем
Слайды